Долбана БД

Саня

Новый пользователь
Всем привет! прошу помощи - ситуация следующая.


запускаю сервер на удаленной машине на дебиан с мариадб сервер работает все хорошо.


Игровой сервер работает - заходить могу все норм


StressWeb все отображает (статистика\онлайн и прочее)


захожу через навикат все отлично, вижу бд могу ее править.





Запустил на этой же машине второй сервер:


После запуска второго сервера на этой же машине


Сервера работают оба, зайти и побегать могу на обоих серверах без проблем.


StressWeb перестает отображать статистику


через навикат уже зайти немогу пишет (2013 lost connection to mysql server at reading initial communication packet'')


Вот такая вот хрень, как будто стоит ограничение на подключение.


Конфиги вот такие в 50-server.cnf

max_connections 1000

Даже с разрешением в 1к подключений все равно второй сервер запускаешь и все нет доступа.
 

Саня

Новый пользователь
в логин сервере
# Максимальное количество подключений к базе данных.
MaximumDbConnections = 10
 

TorraDina

Новый пользователь
[mysqld]
datadir=C:/Program Files/MariaDB 10.4/data
port=ПОРТ
innodb_buffer_pool_size=4095M (по своему усмотрению)
character-set-server=utf8
interactive_timeout=2400 (по своему усмотрению)
wait_timeout=2400 (по своему усмотрению)
max_connections=1800 (по своему усмотрению)
skip-name-resolve
[client]
port=ПОРТ
plugin-dir=C:/Program Files/MariaDB 10.4/lib/plugin


Хоть кол на голове теши. Вот какие настройки должны быть в Марии, чтобы она корректно работала с сайтом и нагрузкой
 

Саня

Новый пользователь
Выставил 6000 и все равно стоит запустить 2 сервера, все хана stressweb ложится и нихрена не отображает и через навикат хрен подключишься(

попробую увеличить #thread_concurrency = 10 чтоли хз)
 

Mayhem

Новичок
Yu can try to increase max connections through the command line of mariadb (This works for me, better than editing the my.cnf)


Log in to the MySQL/MariaDB command line client with the command:
mysql -u root -p (Your credentials)

Set the new max_connections value with the command:

SET GLOBAL max_connections=[desired new maximum number];
Example:
SET GLOBAL max_connections=200;
quit;

after all restart the service and try the new settings.
also you can check if the max connections had changed with the following command:

SHOW variables;
and look for the max_connections variable
 

Саня

Новый пользователь
Это я делал! но теперь разобрался в чем причина, оказывается он у меня настройки не берет с 50-server.cnf, и через консоль выставленное мной значение не сохраняет после рестарта. буду разбираться, но спасибо за наводку так бы через консоль и не перепроверил)))

ENG

I did it! but now I figured out what the reason is, it turns out that he does not take my settings from 50-server.cnf, and through the console, the value I set does not save after the restart. I will understand, but thanks for the tip-off, so I would not double-check through the console)))
 

Саня

Новый пользователь
skip-name-resolve добавлен?
нет, да и зачем мне это?
у меня через консоль выставляется соединение как надо, но через консоль будет работать только до первой перезагрузки. он должен подхватывать конфиги из 50-server.cnf а он этого не делает, вот пытаюсь понять почему.... и права правильно стоят, и путь верный а вот именно max_connections игнорирует
 

TorraDina

Новый пользователь
нет, да и зачем мне это?
у меня через консоль выставляется соединение как надо, но через консоль будет работать только до первой перезагрузки. он должен подхватывать конфиги из 50-server.cnf а он этого не делает, вот пытаюсь понять почему.... и права правильно стоят, и путь верный а вот именно max_connections игнорирует
ааааааа ._. Это нужно для того, чтобы принимать соединения от доменных имен, а в данном случае от сайта
 
Сверху